跳至內容
測試伺服器
開發伺服器

pylon 3D Viewer 概觀#

本主題將為您概述 pylon 3D Viewer 的使用者介面,該介面支援諸如 blaze、Stereo ace 和 Stereo mini 等 Basler 3D 相機。

以下螢幕截圖顯示了 pylon 3D Viewer 的不同元素。

pylon 3D Viewer 使用者介面

應用程式版面配置由以下主要區域組成:

  • 功能表列
  • 多個工具列
  • 左右兩側可停靠的窗格
  • 包含 2D 和 3D 子視窗的影像視窗區域
  • 位於底部的狀態列

檔案功能表#

File 選單提供以下指令:

  • Save Depth and Image Data (Ctrl+S):將深度與影像資料以及相機設定儲存至檔案。提供多種格式可供選擇。如需詳細資訊,請參閱Saving Depth and Image Data。
  • Exit (Ctrl+Q):關閉 pylon 3D Viewer。

檢視功能表#

使用 View 選單來顯示或隱藏 UI 元素。此選單為動態產生,並包含下列項目的切換開關:

  • 工具列(例如 Camera Selector、File、Camera Control、Point Picking)
  • 窗格(例如 Camera Features、Pixel Information、Documentation、Message Log、Depth Histogram、Depth Line Plot)

相機功能表#

The Camera 選單提供以下指令:

  • Rescan: 更新可用相機清單。
  • Open (Ctrl+O):開啟選定的相機。
  • Close (Ctrl+L):關閉作用中的相機。
  • Continuous Shot (F7):開始連續擷取。
  • Stop (F8):停止影像擷取。
  • Automatic Image Adjustment: 自動設定相機參數並調整深度範圍。此功能僅適用於支援的相機型號與功能。
  • Save Features: 將目前的相機 Feature 設定儲存至 .pfs 檔案中。儲存前必須先停止影像擷取。
  • Load Features: 從先前儲存的 .pfs 檔案中載入相機 Feature 設定。

工具功能表#

Tools 選單可讓您執行下列指令。根據相機型號與安裝情況,並非所有項目都可使用。

  • pylon IP Configurator:啟動適用於 GigE 裝置的外部 IP 設定工具。
  • pylon GigE Optimizer:開啟 GigE Vision 相機的網路最佳化對話方塊。
  • Stereo Calibration Tool:啟動外部立體校正工具。
  • Toggle Pick Mode (Alt+P):在單點與雙點挑選模式之間切換。

視窗功能表#

使用 Window 選單來建立與排列影像視窗。

此選單通常包含下列區段:

  • 2D 檢視
  • 3D 檢視
  • 視窗排列與導覽

可用命令包括:

  • 新增深度圖檢視
  • 新增信賴度圖檢視
  • 新增強度影像檢視
  • 新增點雲檢視
  • Close
  • 全部關閉
  • 並排
  • 重疊
  • 下一頁
  • 上一個

在分隔線下方,功能表會顯示目前開啟的子視窗編號清單。作用中的子視窗會被標記出來。

說明功能表#

Help 功能表可讓您存取文件與支援功能。根據相機型號的不同,並非所有項目都可用。

  • pylon 3D Viewer Help (F1):開啟檢視器文件。如果選取了某個 Property,將會開啟該 Property 的上下文相關說明。
  • Basler Product Documentation: 開啟所連接相機的產品文件。
  • Programmer's Guide: 開啟所連接相機型號的程式設計師指南。
  • Open Samples Directory: 開啟包含程式設計範例的資料夾。
  • Check for Software Updates: 開啟 Basler 軟體更新下載頁面。
  • Check for Firmware Updates: 開啟 Basler 韌體更新下載頁面。
  • Update Camera Firmware: 在瀏覽器中開啟相機韌體更新頁面(僅支援的型號)。
  • Download DiagnosticInfo.tar.gz: 從相機下載診斷套件(僅支援的型號)。
  • Show Release Notes: 開啟本機版本資訊(若有提供)。
  • About pylon 3D Viewer: 開啟包含版本和授權資訊的對話方塊。

工具列#

相機選取器工具列#

包含一個相機選擇下拉式選單,其中列出所有目前偵測到的裝置。

檔案工具列#

包含一個 Save 按鈕,用於儲存深度與影像資料。

相機控制工具列#

提供相機指令的快速存取:

  • Open
  • Close
  • Continuous Shot
  • Stop
  • 自動影像調整

點選取工具列#

包含 Toggle Pick Mode,用於在單點和雙點擷取模式之間切換。

窗格#

Camera Features#

Camera Features 窗格會顯示所選相機的 GenICam 特性樹狀結構。

典型用法:

  • 展開和摺疊特性類別。
  • 選取一項特性以在 Documentation 窗格中顯示內容說明。
  • 按下 ++F1++ 以取得特定特性的說明。
  • 讀取並編輯特性(在擷取期間可能會限制編輯)。

像素資訊#

Pixel Information 窗格會顯示所擷取點的位置和深度相關值。

在單點模式下,該窗格會顯示一個所選點的值。

在雙點模式下,該窗格還會顯示兩點之間的差異值(例如, dX, dY, dZ)以及歐幾里得距離。

如需詳細資訊,請參閱 Image Windows。

文件#

Documentation 窗格會顯示在 Camera Features 窗格中所選特性的關聯式資訊。

訊息記錄#

Message Log 窗格會顯示包含嚴重性和時間資訊的應用程式訊息,例如:

  • Information
  • Warning
  • Critical

這有助於對連線、擷取和組態問題進行疑難排解。

深度長條圖#

Depth Histogram 窗格會顯示目前主動場景的深度值分佈(直方圖)。

深度折線圖#

Depth Line Plot 窗格會將兩個所選點之間連線的深度輪廓視覺化(雙點模式)。

根據您的偏好呈現方式,可使用選用的 Invert Depth Axis 設定。

影像視窗區域#

影像視窗區域包含 2D 和 3D 子視窗。預設情況下,檢視器會開啟一組標準視窗。

典型的預設檢視包括:

  • Intensity Image View
  • Depth Map View
  • Point Cloud View

視窗版面配置是按相機類型儲存的。重新連接相同的相機系列時,將會還原先前的版面配置。

所有窗格都可以透過 View 功能表進行停靠、取消停靠、隱藏和還原。

檢視#

點雲檢視 (3D)#

將深度資料顯示為 3D 點雲。

常見選項:

  • Colorization mode
  • Show Axes

根據相機型號和資料,可用的色彩化選項包括:

  • White
  • Intensity
  • Distance
  • Z Axis
  • Confidence Color
  • Intensity Color

深度圖檢視 (2D)#

將範圍/深度圖顯示為 2D 影像。

常見選項:

  • Colorization
  • Depth range slider

典型色彩化選項:

  • 灰色
  • Rainbow

信賴度圖檢視 (2D)#

將信心值顯示為灰階影像。

強度影像檢視 (2D)#

顯示相機的強度或紅外線影像通道。可用通道取決於相機型號。

典型通道包括:

  • Intensity Left
  • Intensity Right
  • Intensity Combined
  • Infrared Left
  • Infrared Right

其他檢視器功能#

點選取#

檢視器支援在 2D 和 3D 檢視中進行點選取。

  • 單點模式:選擇一個點以檢查其數值。
  • 雙點模式:選擇兩個點以比較數值與距離。

快捷鍵:

  • Alt+P:切換單點/雙點模式。
  • Alt+C:清除已選取的點。

自動影像調整#

自動影像調整 會分析當前場景並自動設定適當的深度範圍(DepthMin, DepthMax),前提是連接的相機支援此功能。

狀態列#

狀態列顯示執行階段資訊,例如:

  • 目前 FPS
  • 延遲(依型號而異)
  • 畫面 ID
  • 連接 Quality 指示器

版面配置持久性#

檢視器會儲存並恢復其視窗佈局。

  • 窗格的位置與可見性
  • 開啟 2D/3D 檢視及其排列方式
  • 檢視專屬設定

佈局按相機類型儲存,可讓您在不同的相機系列之間快速切換。