跳至內容
測試伺服器
開發伺服器

pylon 3D Viewer 概覽#

本主題將為您概述「pylon 3D Viewer 」的使用者介面,該軟體支援 Basler 3D 攝影機(例如blaze、 Stereo ace,以及 Stereo mini等。

以下螢幕截圖顯示了「pylon 3D Viewer 」的各項元素。

pylon 3D Viewer User Interface

此應用程式的佈局由以下主要區域組成:

  • 選單列
  • 幾個工具列
  • 可停靠於左側和右側的面板
  • 一個包含 2D 和 3D 子視窗的影像視窗區域
  • 底部的一條狀態列

檔案功能表#

「檔案」選單提供以下指令:

  • 儲存深度與影像資料(Ctrl+S):將深度與影像資料以及相機設定儲存至檔案中。提供多種格式可供選擇。如需更多資訊,請參閱「儲存深度與影像資料」。
  • 退出(Ctrl+Q):關閉pylon 3D Viewer 。

檢視選單#

請使用「檢視」選單來顯示或隱藏使用者介面元件。此選單是動態生成的,其中包含以下項目的切換選項:

  • 工具列(例如:相機選擇器、檔案、相機控制、點選)
  • 面板(例如:「相機功能」、「像素資訊」、「文件」、「訊息日誌」、「深度直方圖」、「深度線圖」)

相機功能表#

「相機」選單提供以下指令:

  • 重新掃描:更新可用攝影機清單。
  • 開啟(Ctrl+O):開啟選定的攝影機。
  • 關閉(Ctrl+L):關閉當前活躍的攝影機。
  • 連續鏡頭(F7):開始連續拍攝。
  • 停止(F8):停止影像擷取。
  • 自動影像調整:自動設定相機參數並調整景深範圍。此功能僅適用於支援的相機型號及功能。
  • 儲存功能:將當前的相機功能設定儲存至.pfs檔案中。儲存前必須先停止影像擷取。
  • 載入設定:從先前儲存的.pfs檔案中載入相機功能設定。

工具功能表#

「工具」選單提供以下指令。視攝影機型號及安裝設定而定,並非所有選項皆可使用。

  • pylonIP Configurator :啟動 GigE 裝置的外部 IP 設定工具。
  • pylon GigE Optimizer:開啟 GigE Vision 攝影機的網路最佳化對話方塊。
  • 立體聲校準工具:啟動外部立體聲校準工具。
  • 切換選取模式(Alt+P):在單點與雙點選取模式之間切換。

視窗功能表#

請使用「視窗」選單來建立和排列影像視窗。

選單通常包含以下這些區塊:

  • 2D 視圖
  • 3D 視圖
  • 視窗佈局與導航

可用的指令包括:

  • 新的深度圖檢視模式
  • 新的信心地圖檢視模式
  • 新的「強度」影像檢視模式
  • 新的點雲檢視模式
  • Close
  • 關閉所有
  • 磁磚
  • Cascade
  • 下一頁
  • 上一頁

在分隔線下方,選單會顯示目前開啟的子視窗清單,並以編號標示。當前處於活動狀態的子視窗會被標示出來。

說明選單#

透過「說明」選單,您可以存取說明文件及支援功能。視相機型號而定,並非所有項目皆可使用。

  • pylon 3D Viewer 說明(F1):開啟檢視器說明文件。若已選取某個功能,說明功能將開啟該功能的上下文相關內容。
  • Basler 產品文件:開啟已連接相機的產品文件。
  • 程式設計師指南:開啟已連接相機型號的程式設計師指南。
  • 開啟範例資料夾:開啟包含程式設計範例的資料夾。
  • 檢查軟體更新:開啟 Basler 的軟體更新下載頁面。
  • 檢查韌體更新:開啟 Basler 的韌體更新下載頁面。
  • 更新相機韌體:在瀏覽器中開啟相機韌體更新頁面(僅限支援的機型)。
  • 下載 DiagnosticInfo.tar.gz:從相機下載診斷套件(僅限支援的機型)。
  • 顯示發行說明:若有的話,將開啟本機端的發行說明。
  • 關於「pylon 3D Viewer 」:開啟一個顯示版本和授權資訊的對話方塊。

工具列#

相機選擇器工具列#

包含一個相機選擇下拉式選單,其中列出所有目前偵測到的裝置。

檔案工具列#

內含一個「儲存」按鈕,用於儲存深度與影像資料。

相機控制工具列#

可快速存取相機指令:

  • Open
  • Close
  • 一鏡到底
  • 停止
  • Automatic Image Adjustment

點選工具列#

包含「切換選取模式」功能,可用於在單點選取與雙點選取之間切換。

窗格#

相機功能#

「相機功能」窗格會顯示所選相機的GenICam 功能樹。

典型用法:

  • 展開與收合功能類別。
  • 選取一項功能,即可在「文件」窗格中顯示相關文件。
  • 按下 ++F1++ 鍵,即可查看特定功能的說明。
  • 讀取與編輯功能(在資料擷取期間,編輯功能可能會受到限制)。

像素資訊#

「像素資訊」窗格會顯示所選點的位置與深度相關數值。

在單點模式下,該窗格會顯示一個選取點的數值。

在雙點模式下,該窗格還會顯示兩點之間的差值(例如, dX, dY, dZ) 以及歐幾里得距離。

詳情請參閱圖片Windows 。

說明文件#

「文件」窗格會顯示針對「相機功能」窗格中選取之功能所提供的上下文相關資訊。

訊息記錄#

「訊息記錄」窗格會顯示包含嚴重程度與時間資訊的應用程式訊息,例如:

  • 資訊
  • 警告
  • 關鍵

這對於排除連線、資料擷取及設定相關的問題非常有用。

深度直方圖#

「深度直方圖」窗格顯示當前活躍場景的深度值分佈(直方圖)。

深度線圖#

「深度線圖」窗格可將兩個選取點之間(雙點模式)的深度剖面以圖形方式呈現。

您可以根據偏好的呈現方式,選擇是否啟用「反轉深度軸」設定。

影像視窗區域#

影像視窗區域包含 2D 和 3D 子視窗。預設情況下,檢視器會開啟一組標準視窗。

常見的預設檢視包括:

  • 強度影像檢視
  • 深度圖視圖
  • 點雲檢視

視窗佈局會依相機類型分別儲存。當重新連接同一系列相機時,系統會還原先前的佈局。

所有窗格均可透過「檢視」選單進行停靠、解除停靠、隱藏及還原。

檢視#

點雲視圖(3D)#

將深度資料以 3D 點雲的形式顯示。

常見選項:

  • 上色模式
  • 顯示軸線

可用的著色效果包括(視相機型號及資料而定):

  • White
  • Intensity
  • 距離
  • Z 軸
  • 信賴度顏色
  • 強度顏色

深度圖視圖(2D)#

將範圍/深度圖以 2D 影像的形式顯示出來。

常見選項:

  • 上色
  • 深度範圍滑桿

常見的上色方式:

  • 灰色
  • 彩虹

置信度地圖視圖(2D)#

將置信度值以灰階影像的形式顯示出來。

強度影像檢視(2D)#

顯示相機的亮度或紅外線影像通道。可用的通道取決於相機型號。

常見的管道包括:

  • 左側強度
  • 右側強度
  • Intensity Combined
  • Infrared Left
  • 右紅外線

其他檢視器功能#

點選選點#

此檢視器支援在 2D 和 3D 視圖中進行點選。

  • 單點模式:選取一個點以檢視其數值。
  • 雙點模式:選取兩個點以比較數值與距離。

快捷鍵:

  • Alt+P: 切換單點/雙點模式。
  • Alt+C: 清除已選取的點。

Automatic Image Adjustment#

Automatic Image Adjustment 分析當前場景,並自動設定適當的深度範圍(DepthMin, DepthMax) 當連接的相機支援此功能時。

狀態列#

狀態列會顯示執行時資訊,例如:

  • 當前每秒幀數 (FPS)
  • 延遲(取決於模型)
  • 幀識別碼
  • 連線品質指標

版面配置的持久化#

檢視器會儲存並還原其視窗佈局。

  • 窗格的位置與可見性
  • 開啟 2D/3D 視圖及其排列方式
  • 視圖特定設定

佈局是按相機類型儲存的,因此可以快速在不同的相機系列之間切換。