跳至內容
測試伺服器
開發伺服器

pylon Viewer 概覽#

pylon Viewer 是一個應用程式,可用於透過圖形使用者介面檢視和變更大部分相機參數設定。

pylon Viewer 是 Basler pylon Software Suite 的一部分。它適用於 Windows、Linux 和 macOS。

主視窗#

pylon Viewer 主視窗

檔案功能表#

使用 File 功能表可結束 pylon Viewer 並儲存目前影像。您可以下列格式儲存影像:

  • 點陣圖
  • Tiff
  • jpg
  • png
  • raw
  • dng

檢視功能表#

View 功能表提供下列指令:

  • Zoom In:放大影像。
  • Zoom Out: 縮小影像。
  • Zoom to Fit: 使影像符合影像顯示區域。
  • Zoom 100%: 將影像恢復為原始大小。
  • Full Screen: 以全螢幕模式顯示您的影像。
  • Tile: 允許您從分頁式影像視窗配置切換為磚格檢視。
  • Clear Message Log: 清除 Message Log 窗格中的所有訊息。
  • Show/Hide Crosshair: 顯示或隱藏影像顯示區域中的 crosshair。
  • Show/Hide Grid: 顯示或隱藏影像顯示區域中的 grid。

相機功能表#

Camera 選單提供用於操作相機、調整相機設定或新增未自動偵測到的 GigE 相機的指令:

  • Open Device: 開啟裝置,即使其可供使用。
  • Close Device: 關閉裝置。
  • Single Shot: 擷取單張影像。
  • Continuous Shot:讓相機持續擷取影像。
  • Stop: 停止擷取影像或停止錄製。
  • Pause: 暫停錄製。
  • Record: 錄製影片。錄製將使用目前的設定開始。如果您想要變更任何設定,請透過 Window 選單開啟 Recording Settings 窗格。
  • Save Features: 將相機特性的目前設定儲存至 .pfs 檔案中。副檔名 ".pfs" 代表 "pylon feature stream"。
  • Load Features: 載入包含先前儲存之相機特性設定的 .pfs 檔案。副檔名 ".pfs" 代表 "pylon feature stream"。
  • File Access: 提供對相機檔案系統的存取權,例如用於上傳或下載 User Sets。
  • Copy Camera Features: 將所有相機特性的目前設定複製到剪貼簿。這可讓您在不同的內容中使用它們。
  • Add Remote GigE Camera: 透過輸入 IP 位址來新增 GigE 相機。如果您想要新增不在您網路中因此無法自動偵測到的相機,這會非常有用。
  • Automatic Image Adjustment: 執行 automatic image adjustment。
  • Static Defect Pixel Correction: 校正 defect pixels。
  • Vignetting Correction: 從您的影像中移除 vignetting artifacts。

工具功能表#

Tools 選單可讓您存取各種工具以及 Options 對話方塊。

工具

選項

  • 一般:您可以自訂 pylon Viewer,並選擇使用線上版還是離線版的說明。
  • 語言:您可以變更 pylon Viewer、pylon IP Configurator 和 pylon USB Configurator 的語言。可用語言包括簡體中文、英文、日文和韓文。
  • 相機模擬:您可以指定 pylon Viewer 中可用的相機模擬裝置數量。
  • 十字線:您可以修改十字線的外觀。
  • 網格:您可以修改網格的外觀。

Workbench 選單#

透過 Workbench 功能表,您可以建立並儲存用於建立影像處理設計的配方。

視窗功能表#

透過 Window 功能表,您可以選擇或取消選取要顯示的窗格,例如 Devices 窗格或 Histogram 窗格。

說明功能表#

使用 Help 功能表提交關於 pylon 應用程式的回饋、聯絡 Basler 支援,以及檢視關於 pylon Viewer 的一般資訊(例如版本和資料隱私資訊)。您也可以存取 Basler 產品說明文件、pylon Deployment Guide、pylon SDK Samples Manual、pylon API documentation、C++ Data Processing Programmer's Guide 以及vTool Licensing 資訊概覽。

工具列按鈕#

圖示 功能
開啟裝置圖示 開啟/關閉目前選取的裝置。
儲存圖示 儲存目前的影像。
單張拍攝圖示 擷取單張影像。
Continuous Shot 圖示 連續擷取影像。
停止圖示 停止擷取影像或停止錄製。
暫停圖示 暫停錄製。
錄製圖示 使用目前的設定開始錄製。如果您想變更任何設定,請透過 Window 功能表開啟 Recording Settings 窗格。
放大圖示 放大影像。
縮小圖示 縮小影像。
縮放至最適大小圖示 使影像剛好符合影像顯示區域。
100% 縮放圖示 將影像還原至原始大小。
全螢幕圖示 以全螢幕模式顯示您的影像。
圖鋪模式圖示 允許您將影像視窗的分頁版面配置切換為圖鋪檢視。
十字線圖示 在影像顯示區域中顯示/隱藏 十字線。
網格圖示 在影像顯示區域中顯示/隱藏 網格。
直方圖圖示 開啟/關閉 Histogram 窗格。
Sharpness Indicator 圖示 開啟/關閉 Sharpness Indicator 窗格。
自動影像調整圖示 讓相機 自動進行所有設定,以便在目前條件下獲得良好的影像。
Workbench 圖示 開啟/關閉 Workbench 窗格。

窗格#

pylon Viewer 提供了多種窗格,用於處理裝置、提供有關裝置和 Property 的資訊,以及使用 pylon Workbench 建立影像處理設計。pylon Viewer 預設版面配置中所包含的窗格列於下方。如需 Workbench 相關窗格的說明,請參閱 Overview of the Workbench。

「裝置」窗格#

Devices 窗格會顯示裝置樹狀結構,其中列出連接到您電腦的所有相機,並依介面類型分組。顯示的介面會根據您在安裝 pylon Software Suite 期間選擇的選項而有所不同。舉例來說,上方的螢幕擷取畫面顯示了 Basler boost、ace、pulse 和 ace 相機以及 camera emulation 裝置。使用 Show Cameras Only 選項,您只需顯示相機而不顯示介面資訊。

在此窗格中,您還可以選擇是否要以固定間隔自動掃描最近連接的裝置。或者,您可以按一下 Refresh 按鈕來手動重新整理裝置樹狀結構:

重新整理圖示

「功能」窗格#

Features 窗格會顯示在 Devices 窗格中選取的相機的 Property。根據預設,它包含兩個分頁:

  • Features – All: 此窗格會列出目前選取的相機上可用的所有 Property。在這裡,您還可以選擇將經常需要或用於特定任務的 Property 分組。如需如何執行此操作的說明,請參閱下方的 To group features。
  • Features – Basic: 此分頁包含一組簡化的 Property,可讓您快速設定相機。

若要將 Property 分組:

  1. 按一下 Edit Feature Tabs 按鈕。
  2. 在 Edit Feature Tabs 對話方塊中,輸入新標籤頁的名稱。
  3. 將所需的 Property 從 Features 窗格拖曳到 Edit Feature Tabs 對話方塊中。
  4. 完成新增 Property 後,按一下 OK。

新的 Property 標籤頁將顯示在 pylon Viewer 中。您可以像其他標籤頁一樣將其釘選(Dock),或是讓它保持浮動。該新標籤頁也將新增至 Window 功能表中。

您可以在所有相機型號上使用此自訂標籤頁,亦即您可以為 ace 2 相機建立標籤頁,並在操作 ace 相機時使用它。由於這些相機型號的 Property 集合不同,因此當您使用 ace 型號時,ace 2 相機上可用的 Property 將不會顯示。如果您想查看這些不可用的 Property,請勾選 Show Unavailable Features 核取方塊。

您建立的 Property 標籤頁可以進行修改。您可以新增 Property、刪除 Property 或變更標籤頁名稱。Features – All 和 Features – Basic 標籤頁無法編輯。

若要編輯 Property 標籤頁:

  1. 按一下 Edit Feature Tabs 按鈕。
  2. 在 Edit Feature Tabs 對話方塊中,選取您要編輯的標籤頁。
  3. 進行所需的變更。
  4. 按一下 OK。

Features – All 標籤頁的另一項功能是 Common Tasks 下拉式清單。這旨在協助您快速完成各種常見任務,例如變更解析度或最佳化影像 Quality。透過選取其中一項任務,相關的 Property 將會在 Property 樹狀結構中反白顯示。

Polling 選項可讓您以規則的間隔自動輪詢相機。或者,您可以按一下 Refresh 按鈕手動重新整理 Property 清單:

重新整理圖示

影像顯示區域#

此處會顯示相機拍攝的圖片與影片。每個目前開啟的相機皆對應一個影像視窗分頁。底部設有狀態列,會顯示您正在擷取的圖片或錄製的影片相關資訊。調整相機位置時,您可以顯示十字準線和網格作為視覺輔助。

點擊工具列上的「全螢幕」按鈕,即可將圖片以全螢幕模式顯示:

全螢幕按鈕

若要將全螢幕影像移至第二螢幕,請在影像上按右鍵,然後點選「螢幕 #2」。影像隨即會移至您的第二螢幕。

「功能說明」窗格#

「功能說明」窗格會顯示關於「功能」窗格中目前所選功能之相關資訊。功能說明提供多種語言版本。請從「語言」下拉式清單中選擇您所需的語言。

「功能 Property」窗格#

「特徵屬性」窗格會顯示關於「特徵」窗格中目前所選參數的相關資訊。初始狀態下,它會以最小化狀態顯示,並停靠在「pylon Viewer 」的右側。

「訊息記錄」窗格#

「訊息記錄」窗格會顯示透過pylon Viewer 執行的操作相關資訊,例如開啟或關閉攝影機,或是開始錄製。訊息分為不同等級:資訊、警告和嚴重。預設情況下,此窗格會以最小化狀態顯示,並停靠在pylon Viewer 的右側。

新增與移除窗格#

透過「視窗」選單,您可以選擇顯示更多面板。預設情況下,其中部分面板會停靠在「pylon Viewer 」的右側,其餘則為浮動式。

若要關閉一個窗格,請在該窗格的標題列上按右鍵,然後點選「關閉」。

重新排列窗格#

若要解除窗格的停靠狀態:

  1. 點擊窗格的標題列,並將其拖曳至您想要的位置,或讓它保持懸浮狀態。

要將窗格停靠:

  1. 開始拖曳窗格。
    將會出現定位輔助工具。
    定位輔助工具
  2. 使用滑鼠游標指向您想要放置窗格的位置。
    目標視窗區域將會以藍色反白顯示。
  3. 放開滑鼠以放置窗格。

以下動畫示範了此操作。

重新排列窗格操作動畫

透過這種方式,您可以完全自訂 pylon Viewer 視窗並依需求重新排列窗格。

若要關閉窗格,請在 Window 選單中取消選取它們。