pylon Viewer 總覽#
pylon Viewer 是 Basler pylon Software Suite 的一部分。它適用於 Windows、Linux 和 macOS。
主視窗#

選單#
檔案功能表#
使用 File 功能表可結束 pylon Viewer 並儲存當前影像。您可以下列格式儲存影像:
- 點陣圖 (Bitmap)
- Tiff
- jpg
- png
- raw
- dng
檢視選單#
View 功能表提供下列命令:
- Zoom In: 放大影像。
- Zoom Out: 縮小影像。
- Zoom to Fit: 使影像適應影像顯示區域。
- Zoom 100%:將影像恢復至原始大小。
- Full Screen:以全螢幕模式顯示影像。
- Tile:允許您將標籤頁面配置的影像視窗切換為拼貼檢視。
- Clear Message Log:清除 Message Log 窗格中的所有訊息。
- Show/Hide Crosshair:在影像顯示區域中顯示或隱藏十字線。
- Show/Hide Grid:在影像顯示區域中顯示或隱藏網格。
相機功能表#
Camera 選單提供用於操作相機、調整相機設定或新增未被自動偵測到的 GigE 相機的指令:
- Open Device:開啟裝置,即使其處於可用狀態。
- Close Device:關閉裝置。
- Single Shot:擷取單張影像。
- Continuous Shot:讓相機連續擷取影像。
- Stop:停止擷取影像或停止錄製。
- Pause:暫停錄製。
- Record:錄製影片。錄製將以目前的設定開始。如果您想要變更任何設定,請透過 Window 選單開啟 Recording Settings 窗格。
- Save Features:將相機特性的目前設定儲存至 .pfs 檔案中副檔名「.pfs」代表「pylon feature stream」。
- Load Features:載入包含先前儲存之相機特性設定的 .pfs 檔案。副檔名「.pfs」代表「pylon feature stream」。
- File Access:提供對相機檔案系統的存取權,例如用於上傳或下載user sets。
- Copy Camera Features:將所有相機特性的目前設定複製到剪貼簿。這可讓您在不同的情境中使用它們。
- Add Remote GigE Camera:透過輸入 IP 位址來新增 GigE 相機。如果您想新增不在您的網路中因而無法被自動偵測到的相機,這會非常有用。
- Automatic Image Adjustment:執行自動影像調整。
- Static Defect Pixel Correction:校正畫素瑕疵。
- Vignetting Correction:消除影像中的暗角偽影。
工具功能表#
Tools 選單讓您能夠存取各種工具以及 Options 對話方塊。
工具
- 頻寬管理員
- Camera API Generator
- Firmware Updater
- Color Calibrator:如需支援此特性的相機清單,請參閱 Color Calibrator 主題。
- 組態工具,取決於安裝的介面:pylon USB Configurator(僅限 Windows)、pylon IP Configurator、pylon CL Configurator(僅限 Windows)
- CXP Tools:這會將您帶至安裝目錄中的資料夾,其中包含用於操作 Basler 介面卡或擷取卡的工具。
選項
- General:您可以自訂 pylon Viewer,並選擇是要使用線上版本還是離線版本的說明。
- Language:您可以變更 pylon Viewer、pylon IP Configurator 與 pylon USB Configurator 的語言。可用的語言包括簡體中文、英文、日文和韓文。
- Camera Emulation:您可以指定 pylon Viewer 中可用的 相機模擬裝置 數量。
- Crosshair:您可以修改 十字游標 的外觀。
- Grid:您可以修改 網格 的外觀。
Workbench 選單#
透過 Workbench 選單,您可以建立並儲存用於 建立影像處理設計 的 recipes。
視窗功能表#
透過 Window 選單,您可以選擇顯示或隱藏所需的 窗格,例如 Devices 窗格或 Histogram 窗格。
說明選單#
使用 Help 選單可提交關於 pylon 應用程式的回饋、聯絡 Basler 支援團隊,以及檢視關於 pylon Viewer 的一般資訊(例如版本和資料隱私資訊)。您也可以存取 Basler 產品文件、pylon Deployment Guide、pylon SDK Samples Manual、pylon API documentation、C++ Data Processing Programmer's Guide 以及 vTool Licensing 資訊總覽。
工具列按鈕#
| 圖示 | 功能 |
|---|---|
| 開啟/關閉目前選取的裝置。 | |
| 儲存目前的影像。 | |
| 擷取單張影像。 | |
| 連續擷取影像。 | |
| 停止擷取影像或停止錄製。 | |
| 暫停 錄製。 | |
| 使用目前的設定開始 錄製。如果您想變更任何設定,請透過 Window 選單開啟 Recording Settings 窗格。 | |
| 放大影像。 | |
| 縮小影像。 | |
| 使影像符合影像顯示區域的大小。 | |
| 將影像恢復為原始大小。 | |
| 以全螢幕模式顯示您的影像。 | |
| 允許您從影像視窗的分頁版面配置切換至拼貼檢視。 | |
| 在影像顯示區域中顯示/隱藏十字線。 | |
| 在影像顯示區域中顯示/隱藏網格。 | |
| 開啟/關閉直方圖窗格。 | |
| 開啟/關閉銳利度指示器窗格。 | |
| 讓相機自動進行所有設定,以便在目前的環境條件下取得良好的影像。 | |
| 開啟/關閉Workbench窗格。 |
窗格#
pylon Viewer 提供了多種窗格,用於處理裝置、提供有關裝置和功能的資訊,以及使用 pylon Workbench 建立影像處理設計。pylon Viewer 預設版面配置中包含的窗格列於下方。如需 Workbench 相關窗格的說明,請參閱Workbench 概覽。
裝置窗格#
裝置窗格會顯示一個裝置樹狀結構,其中列出了連接到您電腦的所有相機,並依介面類型分組。顯示的介面會根據您在安裝 pylon Software Suite 期間所選擇的選項而有所不同。舉例來說,相機模擬裝置以及 Basler boost、ace 2、pulse 和 ace 相機會顯示在上方的螢幕擷取畫面中。使用僅顯示相機選項,您只能顯示相機而不顯示介面資訊。
在此窗格中,您也可以選擇是否以固定間隔自動掃描最近連接的裝置。或者,您也可以按一下重新整理按鈕來手動重新整理裝置樹狀結構:
功能窗格#
功能窗格會顯示在裝置窗格中選取的相機功能。根據預設,它包含兩個分頁:
- 功能 – 全部:此窗格列出了目前選取的相機上可用的所有功能。在這裡,您也可以選擇將您經常需要或用於特定任務的功能分組。如需如何執行此操作的說明,請參閱下方的將功能分組。
- 功能 – 基本:此分頁包含一組簡化的功能,可讓您快速設定相機。
若要將功能分組:
- 按一下編輯功能分頁按鈕。
- 在編輯功能分頁對話方塊中,輸入新分頁的名稱。
- 將所需的功能從功能窗格拖曳到編輯功能分頁對話方塊中。
- 完成新增功能後,按一下確定。
新的功能標籤頁將顯示在 pylon Viewer 中。您可以像其他標籤頁一樣將其停靠或使其浮動。新的標籤頁也將新增至 Window 功能表中。
您可以在所有相機型號上使用此自訂標籤頁,也就是說,您可以為 ace 2 相機建立標籤頁,並在使用 ace 相機時使用它。由於這些相機型號的功能集不同,因此當您使用 ace 型號時將不會顯示 ace 2 相機上可用的功能。如果您想查看這些不可用的功能,請勾選 Show Unavailable Features 核取方塊。
您所建立的功能標籤頁可以進行變更。您可以新增功能、刪除功能或變更標籤頁的名稱。Features – All 和 Features – Basic 標籤頁無法編輯。
若要編輯功能標籤頁:
- 按一下編輯功能分頁按鈕。
- 在 Edit Feature Tabs 對話方塊中,選取您要編輯的標籤頁。
- 進行所需的變更。
- 按一下 OK。
Features – All 標籤頁的另一項功能是 Common Tasks 下拉式清單。這旨在協助您快速完成各種常見任務,例如變更解析度或最佳化影像 Quality。透過選取其中一項任務,相關功能將在功能樹狀結構中反白顯示。
Polling 選項可讓您以固定的時間間隔自動輪詢相機。或者,您可以按一下 Refresh 按鈕來手動重新整理功能清單:
影像顯示區域#
相機拍攝的影像和影片會顯示在此處。目前開啟的每個相機都有一個影像視窗標籤頁。底部是狀態列,提供有關您正在擷取的影像或正在錄製的影片的資訊。定位相機時,您可以顯示十字線和網格作為視覺輔助工具。
按一下工具列上的 Full Screen 按鈕可以全螢幕模式顯示影像:
若要將全螢幕影像移動到第二個螢幕,請在影像中按一下滑鼠右鍵,然後按一下 Screen #2。隨後,影像將移動到您的第二個螢幕。
功能說明文件窗格#
Feature Documentation 窗格會顯示目前在 Features 窗格中選取的功能的相關資訊。功能說明提供多種語言版本。請在 Language 下拉式清單中選擇您的語言。
功能屬性窗格#
Feature Properties 窗格會顯示目前在 Features 窗格中選取的參數的相關資訊。最初,它會以最小化並停靠在 pylon Viewer 右側的形式顯示。
訊息記錄窗格#
Message Log 窗格會顯示使用 pylon Viewer 執行之動作的相關資訊,例如開啟和關閉相機或開始錄製。訊息分為不同的層級:Information、Warning 和 Critical。最初,它會以最小化並停靠在 pylon Viewer 右側的形式顯示。
新增與移除窗格#
透過 Window 功能表,您可以選取更多要顯示的窗格。根據預設,其中一些窗格會停靠在 pylon Viewer 的右側,而其他窗格則會浮動。
若要關閉窗格,請在它的標題列上按一下滑鼠右鍵,然後按一下 Close。
重新排列窗格#
若要取消停靠窗格:
- 按一下窗格的標題列並將其拖曳至您要的位置,或使其保持浮動。
若要停靠窗格:
- 開始拖曳窗格。
隨即會出現一個定位輔助工具。
- 將滑鼠游標指向您要放置窗格的位置。
所需的視窗區域將以藍色反白顯示。 - 放開窗格。
以下動畫展示了這個過程。

這樣,您可以完全自訂 pylon Viewer 視窗,並根據需要重新排列窗格。
若要關閉窗格,請在 Window 選單中取消選取它們。