階層式方塊

VisualApplets 中的 HierarchicalBox 運算子是一個特殊的運算子,可用於建構設計。 如名稱所示,此運算子具有方塊的功能。您可以標記設計的一部分,並使其成為階層式方塊的內容。

階層式方塊在設計中顯示為運算子執行個體(屬於 HierarchicalBox 運算子)。 您可以在個別的設計視窗中檢視和編輯階層式方塊的內容。

階層式方塊包含運算子與連線的組合,並可將其連接至任意數量的輸入和輸出連線。 使用 HierarchicalBox 模組可讓您

  • 非常清晰地建構您的設計,並且

  • 管理模組群組。

在設計面板中,HierarchicalBox 模組顯示為 M 型運算子(橢圓形); 不過,其行為取決於階層式方塊內部的運算子。

下圖顯示 HierarchicalBox 的範例。 如您所見,包含在階層式方塊中的運算子會顯示在獨立的設計視窗中。 根據視窗設定,如範例所示,這兩個圖表可以同時檢視。 請參閱 The User Interface of VisualApplets 以取得更多關於如何配置圖表視窗的資訊。

階層式方塊範例

圖 45. 階層式方塊範例


建立階層式方塊

有幾種方式可以新增階層式方塊:

  • 將設計的一部分變成階層式方塊:

    1. 選取您想要組合為階層式方塊的設計模組。(按住鍵盤上的 Ctrl 鍵,然後按一下您想要組合的模組。)

    2. 按住 Ctrl 鍵不放,並在設計視窗的空白處按一下滑鼠右鍵以開啟內容選單。

    3. 從內容選單中選取 Move to Hierarchical Box。

      系統會建立一個新的階層式方塊,其中包含所有選取的模組以及對應的輸入和輸出連線。

    4. 按兩下階層式方塊以開啟顯示階層式方塊實作的圖表視窗。

  • 定義空白的階層式方塊:

    1. 從 Base 程式庫中選取 HierarchicalBox 運算子並將其新增至您的設計中,或者

      在圖表的空白區域按一下滑鼠右鍵,然後選取 Insert → Hierarchical Box,或者

      從主選單中選取 Design → Hierarchical Box ,或者

      選取圖示 資料夾內的 編輯 工具列。

    2. 在跳出的視窗中,定義您的新 HierarchicalBox 的輸入和輸出連線數量。

    3. 按一下 OK。

      HierarchicalBox 模組會插入至您的圖表中; 它具有您剛剛指定的輸入和輸出連接埠數量。

    4. 按兩下階層方塊模組以開啟其設計視窗。

    5. 新增您希望放在階層方塊中的 operator。

    6. 透過連結將方塊中的設計連接至方塊的輸入和輸出連接埠。

在設計 Windows 之間導覽

若要返回包含階層方塊模組的處理程序之設計視窗:

  1. 按一下設計視窗中的視窗標籤頁:

    設計視窗的視窗標籤頁

    圖 46. 設計視窗的視窗標籤頁


若要在階層中返回上一層:

  1. Select 檢視 → Window Up ( Backspace ) or click the Window Up 按鈕 資料夾內的 檢視 工具列。

編輯模組 Property

若要開啟模組 Property:

  1. 在階層方塊上按一下滑鼠右鍵,然後從內容功能表中選取 "Properties"。 在此處,您可以檢視和編輯可用於參數設定的階層方塊參數。

如需如何讓深層巢狀嵌於受保護階層方塊內的參數 (或作為其他受保護階層方塊一部分的受保護階層方塊內之參數) 在此層級可見並可用的相關資訊,請參閱 Operator Reference 中的「Parameters」library。

重複使用階層式方塊

您可以透過複製與貼上多次使用階層方塊。 階層方塊的每個執行個體都彼此獨立,亦即, 如果您對其中一個複製的階層方塊進行變更,不會影響其他方塊。

如需如何將階層方塊作為 library 元素和受保護 library 元素使用的資訊,請參閱'Creating a User Library Element'一節。

為階層式方塊新增額外連接埠

您可以隨時為階層方塊新增更多輸入和輸出連接埠。若要新增連接埠:

  1. 導覽至顯示階層方塊模組的設計視窗。

  2. 將滑鼠游標移至輸入連接埠(如果您要插入輸入連接埠),或移至輸出連接埠(如果您要插入 輸出連接埠),使 連接埠反白顯示。

    反白顯示連接埠

    圖 47. 反白顯示連接埠


  3. 在連接埠上按一下滑鼠右鍵。

  4. 從內容功能表中選取 Insert Port Above or Insert Port Below。

系統會插入新的連接埠,並賦予預設名稱。若要為連接埠指定自訂名稱,請使用內容功能表項目 Rename Port(見下方)。

刪除階層式方塊的連接埠

您可以隨時刪除階層方塊的輸入或輸出連接埠。若要刪除連接埠:

  1. 導覽至顯示階層方塊模組的設計視窗。

  2. 將滑鼠游標移至您要刪除的連接埠上,使其呈現反白顯示。

  3. 在連接埠上按一下滑鼠右鍵。

  4. 從捷徑功能表中,選取 Remove Port。

該連接埠已被刪除。

重新命名階層式方塊的連接埠

為了提升設計的可讀性,您可以為階層式方塊的輸入和輸出連接埠命名:

  1. 導覽至顯示階層方塊模組的設計視窗。

  2. 將滑鼠游標移至您要重新命名的連接埠上,使其呈現反白顯示。

    反白顯示連接埠

    圖 48. 反白顯示連接埠


  3. 在您要重新命名的連接埠上按一下滑鼠右鍵。

  4. 從捷徑功能表中,選取 Rename Port。

  5. 在 Rename Port 對話方塊中,輸入連接埠的名稱。

    輸入連接埠名稱

    圖 49. 輸入連接埠名稱


  6. 按一下 OK。

新名稱會顯示於(例如)階層式方塊模組的設計視窗中:

已重新命名的階層式方塊連接埠

圖 50. 已重新命名的階層式方塊連接埠


重新排序階層式方塊的連接埠

您可以使用與重新命名完全相同的方式,重新排序階層式方塊模組的連接埠:

  1. 導覽至顯示階層方塊模組的設計視窗。

  2. 將滑鼠游標移至您要變更位置的連接埠上,使其呈現反白顯示。

    反白顯示連接埠

    圖 51. 反白顯示連接埠


  3. 在您要重新排序的連接埠上按一下滑鼠右鍵。

  4. 從捷徑功能表中,選取 Move Port Up 或 Move Port Down。

連接埠的順序隨之互換。這會顯示於(例如)階層式方塊模組的設計視窗中:

已重新排序的階層式方塊輸入連接埠

圖 52. 已重新排序的階層式方塊輸入連接埠


重新安排連接埠順序不會影響階層式方塊的功能。重新安排後的連接埠會與先前一樣,連結至相同的內部與外部設計元素。