階層方塊

該 HierarchicalBox 運算子是VisualApplets 中的一種特殊運算子,可協助建構設計結構。 顧名思義,此運算子具有「方塊」的功能。您可以標記設計中的某個部分,並將其設為 階層化方塊的內容。

在設計中,階層式方塊會以運算子實例(即HierarchicalBox 運算子)的形式顯示。 您可以在獨立的設計視窗中檢視並編輯階層式方塊的內容。

階層式方塊包含運算子與連結的組合,並能將其連接至任意數量的輸入與 輸出連結。 使用 HierarchicalBox 模組,可讓您

  • 讓您的設計結構非常清晰,並要

  • 管理模組群組。

在設計面板中,HierarchicalBox模組以 M 型運算子(橢圓形)的形式顯示; 然而,其行為取決於層級方塊內的運算子。

下圖展示了一個HierarchicalBox 的範例。 如您所見,層級方塊中所包含的運算子會顯示在一個獨立的設計視窗中。 根據視窗設定的不同,可以像範例中所示那樣同時檢視這兩張圖。 請參閱 《使用者介面》VisualApplets ,以瞭解如何安排圖表視窗的相關資訊。

分層方塊的範例

圖 45. 階層式方框的範例


建立階層式方塊

有幾種方法可以新增階層式方塊:

  • 將設計中的某個部分設定為階層式方塊:

    1. 選取您設計中要組裝成階層式方塊的模組。(按下鍵盤上的 STRG 鍵,然後點擊 您要組裝的模組。)

    2. 按住 STRG 鍵,並在設計視窗的空白處按右鍵,即可開啟快顯選單。

    3. 從快顯選單中,選擇 「移至層級方塊」。

      系統會建立一個新的階層式方塊,其中包含所有已選取的模組及其對應的入站與出站連結。

    4. 雙擊一個階層方塊,即可開啟顯示該階層方塊實作的圖表視窗。

  • 定義一個空的階層式方塊:

    1. 從「Base」函式庫中選取HierarchicalBox運算子,並將其新增至您的設計中,或者

      在圖表的空白處按右鍵,然後選取 插入 → 階層式方塊,或

      選擇 設計 → 層級方塊 ,或

      選取圖示 表格中顯示 編輯 工具列。

    2. 在彈出的視窗中,請設定新建立的HierarchicalBox 的輸入與輸出連結數量。

    3. 按一下 OK。

      HierarchicalBox模組已插入您的圖中; 它具有您剛才指定的輸入與輸出埠數量。

    4. 雙擊階層式方塊模組,以開啟其設計視窗。

    5. 將您希望在層級方塊中包含的運算子加入其中。

    6. 請透過連結線,將方框中的設計與方框的輸入及輸出埠連接起來。

在設計 Windows 之間導覽

若要返回包含「階層式方塊」模組的流程之設計視窗:

  1. 在設計視窗中,點擊「視窗」標籤頁:

    設計視窗的標籤頁

    圖 46. 設計視窗的標籤頁


若要回到層級結構中:

  1. Select 檢視 → 升起車窗 ( Backspace ) 或點擊 升起車窗 按鈕 in the 檢視 工具列。

編輯模組 Property

要開啟模組的屬性:

  1. 在階層框上按右鍵,並從快顯選單中選取「屬性」。 在此處,您可以檢視及編輯該階層框中可供參數化的參數。

有關如何將深層嵌套於受保護的分層方塊內 (或嵌套於另一個受保護的分層方塊中的受保護分層方塊內) 的參數,使其在此層級可見且可使用,請參閱《運算子參考》中的「參數」函式庫。

重複使用階層方塊

您可以透過複製與貼上,重複使用層級方塊。 每個層級方塊的實例都與其同級元素相互獨立,也就是說, 若您對其中一個複製的層級方塊進行變更,這不會影響其他實例。

有關如何將階層式方塊用作函式庫元素及受保護函式庫元素的資訊,請參閱「建立使用者函式庫元素」一節。

在階層式方塊中插入額外 Port

您可以隨時為您的階層式方塊新增輸入和輸出連接埠。若要新增連接埠:

  1. 導航至顯示階層式方塊模組的設計視窗。

  2. 將滑鼠游標移至輸入埠(若要插入輸入埠),或移至輸出埠(若要插入 輸出埠),以 使該埠被標示出來。

    重點介紹一個港口

    圖 47. 選取一個連接埠


  3. 在該埠上按右鍵。

  4. 從快顯選單中,選擇 「在上方插入連接埠」 或 「在下方插入連接埠」。

新埠已插入,並被賦予預設名稱。若要為該埠指定自訂名稱,請使用快顯選單項目 「重新命名連接埠」 (參見下文)。

刪除階層方塊的 Port

您可以隨時刪除層級方塊的輸入或輸出連接埠。若要刪除連接埠:

  1. 導航至顯示階層式方塊模組的設計視窗。

  2. 將滑鼠游標移至您要刪除的連接埠, 使其被標示出來。

  3. 在該埠上按右鍵。

  4. 從快顯選單中,選取 「移除連接埠」。

該埠已被刪除。

重新命名階層方塊的 Port

為了提高設計的可讀性,您可以為階層式方塊的輸入埠和輸出埠命名:

  1. 導航至顯示階層式方塊模組的設計視窗。

  2. 將滑鼠游標移至您要重新命名的連接埠上,使其被標示出來。

    重點介紹一個港口

    圖 48. 標示連接埠


  3. 在您要重新命名的埠上按右鍵。

  4. 從快顯選單中,選擇 重新命名埠。

  5. 在對話方塊中 「重新命名連接埠」中,輸入該埠的名稱。

    輸入港名

    圖 49. 輸入埠名


  6. 按一下 OK。

例如,在階層式方塊模組的設計視窗中,即可看到這個新名稱:

層級式盒子中已重新命名的連接埠

圖 50. 階層式方塊中已重新命名的連接埠


重新排序階層式方塊的 Port

與重新命名的方式完全相同,您可以重新排列階層式盒型模組的埠順序:

  1. 導航至顯示階層式方塊模組的設計視窗。

  2. 將滑鼠游標移至您要變更位置的連接埠上,使其被標示出來。

    標示一個港口

    圖 51. 選取連接埠


  3. 在您要重新排序的埠上按右鍵。

  4. 從快顯功能表中,選擇 「將埠向上移動」 或 將埠向下移動。

埠的順序被調換了。例如,在階層式方塊模組的設計視窗中即可看到這一點:

重新排列階層式方塊的輸入埠

圖 52. 層級方塊的重新排序輸入埠


重新排列連接埠的順序,不會影響階層式方塊的功能。 重新排列後的連接埠仍與先前相同的內層及外層設計元件相連。