主程式視窗

VisualApplets 提供了一個用於設計小程式的圖形化使用者介面。 無需撰寫腳本,也無需編輯任何程式碼。 此使用者介面非常簡潔,並特別設計為讓使用者能輕鬆上手。 無需具備程式設計的技術背景。

VisualApplets 的主程式視窗由幾個工具列和面板組成:

主程式視窗

圖 11. 主程式視窗


主選單列可讓您直接存取程式功能。 請使用工具列按鈕快速存取重要功能。您可以在 「設定」 → 系統設定 → 「一般」:

三個面板提供了不同的資訊與功能:

  • 設計面板:設計面板顯示您的VisualApplets 專案。 您始終會有一個主要設計視窗,但根據專案的結構,您可能還會使用 多個子視窗。 在 「視窗」 選單中,可選擇多種檢視模式(平鋪、層疊、分頁檢視)。 透過位於 視窗 → 圖表Windows ( Ctrl+F8 ), 您便能輕鬆選取當下想要進行作業的設計圖窗。

  • 資訊面板: 在主程式視窗的預設設定下,資訊面板會始終顯示。 它以分頁視圖形式提供各種資訊視窗:

    • Project Info

    • Module Info

    • Parameter Info

    • DRC Log

    • Build Log

    • Help

    (關於各個資訊視窗的詳細資訊,請參見下方。)

  • 函式庫面板:在主程式視窗的預設設定下,函式庫面板會始終顯示。 它以分頁視圖形式提供三個函式庫視窗:

    • 運算子函式庫:運算子函式庫是一組包含VisualApplets 運算子的子函式庫集合,也就是各個 影像處理函式。

    • 使用者函式庫:使用者函式庫可包含自訂函式庫,其中包含使用者定義的運算子組合(階層式方塊)。 如需更多資訊,請參閱「使用者函式庫」。

    • 自訂函式庫:若要將運算子匯入自訂函式庫,您需要一個 專家 授權,或 VisualApplets 4 授權。

[提示] 特定 Operator

「運算子庫」中顯示的某些運算子,可能不適用於您目前正在設計的平台。 若該運算子不適用於您所選的平台,則會以灰色顯示。

Operator 不適用於目前選定的目標硬體平台

圖 12. 目前選取的目標硬體平台不支援此運算子


資訊面板的 Windows

Project Info

「專案資訊」(Project Info) 視窗摘要了目前專案的相關資訊。

Project Info

圖 13. 專案資訊


提供以下資訊:

  • 名稱 (Name):專案名稱 (= 檔案名稱)

  • 建立日期 (Creation Date):建立日期

  • 上次修改 (Last Modified):上次修改日期

  • 版本:專案的版本號;此項目可從 設計 → 專案詳細資訊 選單中編輯此項目 (請參閱「專案屬性」)

  • 說明:專案的文字描述;此項目可從 設計 → 專案詳細資訊 選單中進行編輯 (請參閱「專案屬性」)

  • 類型:顯示目標硬體上目前使用的 FPGA 類型 (請參閱「目標硬體移植」)

  • 目標執行階段 (Target Runtime):顯示目標執行階段(請參閱 '目標執行階段')

  • 設計規則檢查第 1 級:顯示發現的錯誤或成功執行結果 (請參閱「設計規則檢查」)

  • 硬體小程式:表示存在硬體小程式。 若VisualApplets 先前曾為該專案產生過 HAP 檔案,則此項目會被勾選。

  • 資源 (Resources):顯示資源估算結果。另請參閱 'FPGA 資源估算'。

  • 系統:顯示偵測到的 XILINX 版本、可用的 Framegrabber SDK 版本,以及Framegrabber SDK 的安裝目錄。 這些資訊將由VisualApplets 用於建立 HAP 以及最終的 HAP 輸出。 詳情請參閱「建置」。

Module Info

「模組資訊」視窗會顯示專案中所有已使用模組的清單(前提是該視窗的輸入欄位為空)。 此清單的結構依循專案的層級架構。

模組搜尋

圖 14. 模組搜尋


在「模組資訊」視窗中,您可以輕鬆搜尋特定的模組或模組類型。這在處理 大型設計時非常有幫助。 開始搜尋之前,您應先設定篩選條件:

  • 若要搜尋您為該模組所設定的自訂名稱,請啟用「名稱」功能。

  • 若要搜尋模組類型(即您目前正在搜尋其實例的運算子名稱), 請啟用「類型」功能。

模組搜尋

圖 15. 模組搜尋


現在您可以輸入搜尋字串。只需輸入名稱的一部分即可。 點擊「模組資訊」視窗中列出的其中一個模組,即可將對應的設計視窗設為焦點(在設計面板中), 並選取該模組並加以標示。

Parameter Info

「參數資訊」視圖會顯示當前設計中的所有參數及其運算子。 您也可以在「參數資訊」視圖中編輯這些參數。

Parameter Info

圖 16. 參數資訊


「參數資訊」視圖提供了一項搜尋功能,讓您可以搜尋參數、參數值或運算子名稱。 您可以使用「僅執行時參數」篩選器,僅顯示動態參數,也就是在執行期間可以編輯的參數。

DRC Log

「DRC 記錄」視窗會顯示上次設計規則檢查的結果。 若點擊警告/錯誤訊息下方列出的其中一個模組名稱,系統將將對應的設計視窗置於 焦點位置(在設計面板中),並 選取該模組並加以標示。

DRC Log 資訊

圖 17. DRC 日誌資訊


Build Log

Build Log 視窗會顯示上一次建置的結果。

Build Log 資訊

圖 18. 建置日誌資訊


Help

「說明」視窗會針對個別運算子提供情境式說明。

若要開啟內容相關說明,您可以:

  1. 請直接在您的設計中選取您想查詢資訊的運算子,然後按下 F1 即可開啟「說明」視窗並顯示對應的資訊。

  2. 請從「運算子庫」視窗中選取一個運算子。 「說明」視窗將始終顯示當前選取項的說明。

範例:顯示 MergeKernel 運算子的相關資訊

圖 19. 範例:在 MergeKernel 運算子上顯示資訊


若您按下 F1 ,或點擊任何其他視窗中的「說明」按鈕,系統將開啟針對當前選取視窗或 函式所提供的情境式使用者手冊說明。 當然,您也可以直接從這份使用者文件存取操作員說明。請參閱《操作員參考手冊》。

程式庫面板的 Windows

「函式庫」面板以分頁式 檢視方式顯示「運算子函式庫」視窗、「使用者函式庫」視窗及「自訂函式庫」視窗。

所有函式庫(運算子函式庫、使用者函式庫,以及自訂函式庫及其所有子函式庫)皆以樹狀 結構進行組織。 每個函式庫都包含運算子。

您可以透過選擇「樹狀圖」、「清單」或「圖示」檢視模式,來變更結構的視覺化呈現方式。

顯示 Operator Library 的程式庫面板

圖 20. 顯示「操作員庫」的庫面板


在搜尋欄中,可輸入搜尋字串,以篩選清單,僅顯示所需的操作員。 以「相機」 ,例如,系統將列出所有包含 camera 的操作員。

Operator Library

「運算子函式庫」是一組包含VisualApplets 運算子的子函式庫集合,也就是各項獨立的影像處理 函式。

您可透過在「運算子庫」視窗中點選運算子名稱, 並在資訊面板中點選「說明」索引標籤,以取得各運算子的詳細資訊。

顯示 Operator Library 的程式庫面板

圖 21. 顯示「操作員庫」的庫面板


有關如何在圖中新增運算子,請參閱「插入運算子」。 所有運算子的詳細說明請參閱《運算子參考》。

User Library

「使用者函式庫」可包含自訂函式庫,其中包含使用者自訂的運算子組合(階層式方塊)。 如需更多資訊,請參閱「使用者函式庫」。

Custom Library

若要將運算子匯入「自訂函式庫」,您需要一個 專家 授權,或是 VisualApplets 4 授權。

調整主程式視窗

您可以透過多種方式,將《VisualApplets 》的主程式視窗調整為符合您個人偏好的樣式:

調整工具列

您可以透過拖放來重新排列工具列,或透過滑鼠右鍵點擊來新增/移除工具列。

還原主程式視窗的預設設定

如果您不小心將視窗或工具列排列成非預期的樣式,您可以透過以下方式還原預設設定: 視窗 → 重設 DockWindows ( Ctrl+O ) 或點擊對應的圖示 在「檢視」工具列中。

File -> Recent Designs 下的檔案數量

在 「檔案」 → 「最近的設計」 VisualApplets 會顯示您最近開啟的VisualApplets 檔案 (*.va) 清單。您可以設定實際顯示的 檔案數量。

若要定義要顯示多少個最近開啟的檔案:

  1. 前往選單 設定 → 系統設定 並選擇類別 「一般」。

  2. 在 「近期設計」下,請設定您希望顯示的檔案數量(最多 24 個)。

  3. 請與 確定。

設定顯示的最近設計數量

圖 22. 設定顯示的最近設計數量