相機校準#
若要將相機用作測量儀器,必須確切了解相機參數,例如 focal length、鏡頭畸變以及相機之間的相互關係。這些參數是透過校正來確定的,並用於影像校正,這是所有後續影像處理的基礎。Stereo ace 相機會根據相機的校正自動進行影像校正。
Stereo ace 相機在出廠時已經過校正。如果 Stereo ace 相機受到強大機械力(例如掉落)的影響,則可能需要重新校正。如果相機突然無法提供任何 3D 資料,您就可以知道需要重新校正。
Self-Calibration#
Stereo ace 相機具有自我校正模式,會在背景以低頻率執行。在此模式下,相機觀察兩個校正影像中線條的對齊情況。機械撞擊(例如相機掉落)可能會導致對齊不準確。如果偵測到明顯的對齊不準確,將會自動進行修正。
若要啟用自我校正,請設定 BslSelfCalibration 參數設為 On.
的值 BslSelfCalibrationUpdateCounter 參數會在每次自動修正時增加。在手動重新校正相機後,它會重設為 0.
在正常條件下(例如 Stereo ace 相機未受到機械撞擊),絕不應發生自我校正。自我校正可讓 Stereo ace 相機在偵測到對齊不準確後仍能正常運作,因為它會自動進行修正。不過,Basler 建議在出現以下情況時手動重新校正相機: BslSelfCalibrationUpdateCounter 不是 0.
Manual Calibration#
在手動校正期間,必須在不同的姿勢下偵測 calibration grid。握住校正網格時,請確保網格的所有黑色方塊在兩個相機影像中完全可見且未被遮擋。成功偵測到的方塊會獲得綠色打勾標記。必須正確偵測所有黑色方塊以確保正確校正。如果有些方塊根本未被偵測到或僅短暫偵測到,原因可能是照明條件不佳或網格受損。校正網格過度曝光部分中的方塊會以紅色突顯。在這種情況下,您必須調整照明條件或曝光設定。校正網格周圍粗大的綠色邊框表示它已在兩個相機影像中被正確偵測。
將校正網格握在相機前面,確保網格的所有黑色方塊在兩個相機影像中完全可見且未被遮擋。成功偵測到的方塊會獲得綠色打勾標記。必須正確偵測所有黑色方塊以確保正確校正。如果有些方塊僅短暫可見或根本未被偵測到,原因可能是照明條件不佳或網格受損。校正網格過度曝光部分中的方塊會以紅色突顯。在這種情況下,您必須調整照明條件或曝光設定。校正網格周圍粗大的綠色邊框表示它已在兩個相機影像中被正確偵測。
可以使用 Stereo Calibration Tool 執行手動校正。按一下 Tools > Stereo Calibration Tool 從 pylon 3D Viewer 啟動此工具。此工具針對校正的各個步驟提供不同的分頁。以下將詳細說明這些分頁:
- Initial settings
- Adjust Focus
- Verify Calibration
- Calibrate
- Monocalibration
- Calculate
- Save
Initial Settings#
若要開始校正程序,您必須選擇相機和校正網格。
- 在 pylon 3D Viewer 的 Tools 功能表中,按一下 Stereo Calibration Tool 以啟動工具。
- 在 Stereo Calibration Tool 的 File 功能表中,按一下 Connect Camera。
隨即會開啟 Select Camera 對話方塊。可用的相機會自動列在其中。 - 選擇所需的相機。
- 在 Calibration Grid 下拉清單中,選取所需的校正網格。
- 按一下 OK。

Verify Calibration#
現在,您可以驗證目前的校正。典型的校正誤差低於 0.2 個像素。如果您相機顯示的誤差在此範圍內,您可以結束校正程序。如果校正誤差較大,您應該繼續進行校正程序,以確保最佳的相機效能。
若要執行驗證,請將網格拿在相機前方,讓兩台相機同時能夠看到它。只要偵測到網格,就會自動計算校正誤差,並將結果顯示在畫面上。
如果您想繼續進行校正,請按一下 Calibrate。

資訊
為了計算出有意義的校正誤差,網格應盡可能靠近相機。如果網格僅覆蓋相機影像的一小部分,校正誤差一定會比網格覆蓋完整影像時還要低。因此,除了目前網格位置的校正誤差外,還會顯示驗證期間的最小與最大校正誤差。
Calibrate#
在開始校正之前,請指定合適的 Exposure Time。為了達到良好的校正結果,影像應有良好的曝光並避免動作模糊。因此,Exposure Time 應盡可能縮短,同時仍能讓場景獲得良好的曝光。
完整校正包括分別校正每台相機(單眼校正),以及執行立體校正以判定相機之間的關係。在大多數情況下,每台相機的內部校正會保持完好。因此,在重新校正期間預設會略過單眼校正,但可以透過按一下 Monocalibration 按鈕來執行。
在立體校正期間,會互相校正兩台相機以尋找其相對旋轉和平移。
首先,應將網格盡可能靠近相機並保持完全靜止。網格必須完全顯示在兩個影像中,且相機應垂直對著網格。如果網格未垂直於相機的視線,指向網格角落預期位置的小綠色箭頭將會指示此情況。

網格必須保持完全靜止。如果發生動作模糊,將無法偵測到網格。繪製在影像上的所有網格儲存格都必須被校正網格覆蓋。這透過將覆蓋的儲存格填滿綠色來視覺化。
一旦覆蓋了所有網格儲存格,它們就會消失並顯示單一的遠處儲存格。現在,應將網格拿得盡可能遠離相機,以便覆蓋小儲存格。箭頭將指示網格是否仍然太靠近相機。當在遠處姿勢成功偵測到網格時,儲存格會填滿綠色並可計算結果。
如果立體校正產生令人不滿意的校正誤差,您應該先執行單眼校正,然後重複立體校正。
Monocalibration#
單眼校正即每台相機各自的內部校正。由於內部校正通常保持完好,因此只有在立體校正結果不令人滿意時才需要執行單眼校正。
進行單眼校正時,必須將網格以特定姿勢拿在相機前方。網格角落指向綠色區域的箭頭表示所有網格角落都應放置在綠色區域內。綠色區域稱為敏感區域。Size of Sensitive Area 滑桿可以控制其大小以簡化校正。不過請注意,將其大小增加過多可能會導致校正準確度略為降低。

單眼校正程序包含每台相機的五個姿勢。將網格的角落或邊緣放置在敏感區域上方後,程序會自動顯示下一個所需的姿勢。左相機的程序完成後,右相機也會重複相同的程序。
Calculate#
按一下 Calculate 按鈕即完成程序並顯示最終結果。所指示的結果是所有校正點的平均重投影誤差。其單位為像素,通常小於 0.2。

Save#
立即按一下 Save 以套用校正並將其儲存至 Stereo ace 裝置。