blaze Viewer 概覽#
以下螢幕擷取畫面顯示了 blaze Viewer 的各個元素。

功能表#
檔案功能表#
File 選單提供以下指令:
- Save Depth and Image Data:將深度和影像資料以及相機設定儲存至檔案。提供多種可用格式。如需詳細資訊,請參閱 Saving Depth and Image Data 主題。
- Exit:關閉 blaze Viewer。
檢視功能表#
使用 View 功能表可選取或取消選取您要顯示的窗格。
相機功能表#
The Camera 選單提供以下指令:
- Rescan:檢查是否已開啟其他相機。
- Open:開啟相機,亦即使其可供使用。
- Close:關閉相機。
- Continuous Shot:讓相機持續擷取影像。
- Stop:停止影像擷取。
- Save Features:將相機功能目前設定儲存至 .pfs 檔案中,該檔案可用任何標準文字編輯器開啟。儲存功能設定之前,必須先停止影像擷取。
- Load Features:載入包含先前儲存之相機功能設定的 .pfs 檔案。
工具功能表#
Tools 功能表可讓您存取 pylon IP Configurator 與 Camera Calibration Tool。
視窗功能表#
使用 Window 功能表來開啟和關閉影像視窗,並在影像視窗區域中加以排列。
說明功能表#
Help 功能表可讓您存取各種說明文件與說明功能。
- blaze Viewer Help:開啟此主題。
- Basler Product Documentation:開啟 blaze 相機說明文件。
- Check for Firmware/Software Updates:帶您前往可檢查韌體/軟體更新的網站。
- Update Camera Firmware:在瀏覽器中開啟軟體更新工具 (Software Update Tool)。
- Download DiagnosticInfo.tar.gz:如果您已使用 Diagnostic Information 功能,則下載包含診斷資訊的檔案。
- blaze Samples:開啟包含 blaze 程式設計範例的資料夾。
- blaze Programmer's Guide:開啟 blaze Programmer's Guide。
- Release Notes:開啟版本資訊。
- About blaze Viewer:開啟包含 blaze Viewer 版本資訊的對話方塊。
窗格#
功能#
在 Features 窗格中,會顯示在相機選擇器中所選相機的所有可用 Property。其中也包含 User Level 下拉式清單,供您選擇您的專業等級。可用選項包含 Beginner、Expert 與 Guru。在 Beginner 等級下,Features 窗格僅會顯示最基本的相機設定。在 Expert 等級下,Features 窗格會顯示最常用的相機設定。在 Guru 等級下,Features 窗格則會顯示所有相機 Property,包含最高階的項目。
您可以將最常使用的 Property 放在 Favorites 類別中。這能讓您快速存取,並免去在 Property 樹狀結構中導覽的麻煩。將 Property 新增至我的最愛並不會將其從 Property 樹狀結構的原始類別中移除。當您關閉 blaze Viewer 時,我的最愛設定仍會保留。
在 Features 窗格中,您也可以選擇是否要以固定間隔自動輪詢相機以取得更新的參數值。或者,您也可以按一下 Refresh 按鈕來手動重新整理 Property 清單。
![]()
像素資訊#
在其中一個影像視窗中所選像素的相關資訊會顯示於 Pixel Information 窗格中。如需關於 Pixel Information 窗格的詳細資訊,請參閱 Using the Pixel Information Pane。
文件#
有關目前在 Features 窗格中所選 Property 的資訊會顯示於 Documentation 窗格中。在上述範例中,選取的是 Operating Mode 參數。此窗格也包含程式碼片段,在撰寫您自己的應用程式代碼時會相當實用。
訊息記錄#
Message Log 窗格會顯示使用 blaze Viewer 執行之動作的相關資訊,例如開啟和關閉相機或開始影像擷取。訊息層級分為三種:Information、Warning 與 Critical。
影像視窗區域#
此窗格包含四個視窗,分別顯示目標場景的不同 2D 與 3D 檢視。
所有窗格都備有按鈕,可用於關閉窗格以及將其從 blaze Viewer 視窗取消嵌棧 (undock)。如果將窗格取消嵌棧,您就可以在桌面上自由移動它。若要重新嵌棧,請按照下列步驟操作:
- 將窗格拖曳至視窗中的所需位置,直到出現虛線矩形框為止。
- 放開滑鼠以放置窗格。