跳至內容
測試伺服器
開發伺服器

blaze Viewer 概覽#

本主題將為您概述 blaze Viewer 的使用者介面。

以下螢幕擷取畫面顯示了 blaze Viewer 的各個元素。

blaze Viewer 使用者介面

檔案功能表#

File 選單提供下列指令:

  • 儲存深度和影像資料:將深度和影像資料以及相機設定儲存至檔案中。提供多種格式。如需詳細資訊,請參閱儲存深度和影像資料主題。
  • 結束:關閉 blaze Viewer。

檢視選單#

使用檢視功能表來選取或取消選取您想要顯示的窗格。

相機功能表#

Camera 選單提供下列指令:

  • 重新掃描:檢查是否有開啟其他相機。
  • 開啟:開啟相機,使其可用於操作。
  • 關閉:關閉相機。
  • Continuous Shot:讓相機連續擷取影像。
  • 停止:停止影像擷取。
  • 儲存功能:將相機功能的目前設定儲存至 .pfs 檔案中,該檔案可以使用任何標準文字編輯器開啟。必須先停止影像擷取,才能儲存功能設定。
  • 載入功能:載入包含先前儲存之相機功能設定的 .pfs 檔案。

工具功能表#

工具功能表可讓您存取 pylon IP Configurator 和相機校正工具。

視窗功能表#

使用視窗功能表來開啟和關閉影像視窗,並在影像視窗區域中排列它們。

說明選單#

說明功能表可讓您存取各種說明文件與說明功能。

  • blaze Viewer 說明:開啟此主題。
  • Basler 產品說明文件:開啟 blaze 相機說明文件。
  • 檢查韌體/軟體更新:引導至您可以檢查韌體/軟體更新的網站。
  • 更新相機韌體:在瀏覽器中開啟軟體更新工具。
  • 下載 DiagnosticInfo.tar.gz:如果您已使用診斷資訊功能,則下載包含診斷資訊的檔案。
  • blaze 範例:開啟包含 blaze 程式設計範例的資料夾。
  • blaze Programmer's Guide:開啟 blaze Programmer's Guide。
  • 版本資訊:開啟版本資訊。
  • 關於 blaze Viewer:開啟包含 blaze Viewer 版本資訊的對話方塊。

窗格#

功能#

功能窗格會顯示在相機選擇器中所選相機上可用的所有功能。它還包含使用者層級下拉式清單,您可以在其中選取您的專業知識層級。可用選項包括初學者、專家和大師。在初學者層級,功能窗格只會顯示最基本的相機設定。在專家層級,功能窗格會顯示最常用的相機設定。在大師層級,功能窗格會顯示所有相機功能,包括最高階的功能。

您可以將最常使用的功能放置在 Favorites 分類中。這可讓您快速存取,並避免在功能樹狀結構中進行導覽。將功能新增至我的最愛並不會將其從功能樹狀結構的原有分類中移除。當您關閉 blaze Viewer 時,我的最愛仍然會保留。

在 Features 窗格中,您也可以選擇是否要以固定間隔自動輪詢相機以取得更新的參數值。或者,您也可以按一下 Refresh 按鈕來手動重新整理功能清單。

Refresh 按鈕

像素資訊#

Pixel Information 窗格會顯示您在其中一個影像視窗中所選取像素的相關資訊。如需關於 Pixel Information 窗格的詳細資訊,請參閱 Using the Pixel Information Pane。

說明文件#

Documentation 窗格會顯示目前在 Features 窗格中選取之功能的相關資訊。在上面的範例中,選取了 Operating Mode 參數。此窗格也包含在撰寫您自己的應用程式碼時可能會派上用場的程式碼片段。

訊息記錄#

Message Log 窗格會顯示使用 blaze Viewer 執行之動作的相關資訊,例如開啟和關閉相機或開始影像擷取。訊息層級分為多種:Information、Warning 和 Critical。

影像視窗區域#

此窗格包含四個視窗,顯示目標場景的不同 2D 和 3D 檢視。

所有窗格都備有按鈕,可用於關閉窗格以及將其從 blaze Viewer 視窗中取消停駐。如果窗格已取消停駐,您可以在桌面上自由移動它。如果您想要重新將其停駐,請遵循下列步驟:

  1. 將窗格拖曳至視窗中的所需位置,直到出現虛線矩形為止。
  2. 放開窗格。