使用 Framegrabber SDK 設定 CXP 線陣相機與擷取卡#
如需關於需求與可能拓撲的資訊,請參閱 General Information。
安裝 Framegrabber SDK#
需要管理員權限
若要安裝 Framegrabber SDK,您的電腦必須具備管理員權限。
若要安裝 Framegrabber SDK 以搭配 Basler racer 2 相機使用:
- 下載 Framegrabber SDK 5.11.2 或更新版本。
- 啟動安裝程式並依照指示完成安裝。
- 在 Select Components 對話方塊中,選取 Full installation,並確保在元件清單中選取了 GenTL Producer。

如需詳細的安裝說明,請參閱 Basler 產品說明文件中的 Installing the Framegrabber SDK 主題。
microDisplay X 入門#
-
若要初步檢視影像,請開啟 microDisplay X。
-
設定一些基本設定,這有助於簡化使用 Basler racer 2 相機進行影像擷取的流程:
- 在 工具 > Settings > Acquisition,請將 Number of Buffers 設定為
100下。這可讓您瀏覽已擷取的影像,這對於相機校正非常有用。 -
將 Acquisition Timeout 設為較高的值,例如
1000 s。這對於設定觸發是必要的,並可避免發生逾時。
-
在 Tools > Settings > Discovery 下,選取 Autoconnect discovered cameras 核取方塊。

- 在 工具 > Settings > Acquisition,請將 Number of Buffers 設定為
-
在 microDisplay X 中載入 applet。請參閱可能的拓撲結構以找出您的設定所需的 applet。

-
按兩下 applet 名稱。現在,擷取卡 FPGA 已使用您的 applet 進行設定。
-
由於您已選取 Autoconnect discovered cameras,相機現在應已連線:

-
您現在可以在 Applet Layout 窗格中按一下 DMA 0 或 Cam 0,以在相機與擷取卡或介面卡的參數之間切換。如果您已將多部相機連線至一部或多部擷取卡或介面卡,您可以在此處選取相機和 DMA 通道。
- 根據需要設定相機和擷取卡或介面卡。
-
重要的擷取卡或介面卡參數必須與相機設定相符。這些參數包括:
- CoaXPress > Pixel Format
- ROI > Width
- 對於 ROI > Height,請定義您所需的影像高度。此參數值定義輸出相機的行數。

-
若要開始影像擷取,請切換至 Acquisition Channel 資料夾內的 Viewing 窗格,然後按一下
Play 按鈕。 -
microDisplayX 可協助您設定擷取卡 ROI。對於線掃描相機,請按一下 Ignore。

只要相機和擷取卡或介面卡處於free run mode,您現在就會看到相機影像。

使用 CoaXPress 行觸發#
若要使用 CoaXPress 線觸發,請將相機設定為 CoaXPress 觸發模式,並如下設定相機和擷取卡或介面卡:
設定參數前請停止影像擷取
在設定任何參數之前,您必須先停止影像擷取。否則,某些參數將無法編輯。
- 在 Applet Layout 窗格中,選取 Cam 0。
-
在 Parameter Selection 窗格的 Acquisition Control 下,設定下列參數:
Trigger Mode=OnTrigger Source=Cxp Trigger 0

根據預設,擷取卡會使用週期為 200 µs 的內部產生器。若要變更來源或使用 軸編碼器,請選取 DMA 0 資料夾內的 Applet Layout 窗格並為您的硬體設定配置 Line Trigger / ExSync 參數: 
如需參數的詳細說明,請參閱 imaFlex CXP-12 Quad、imaWorx CXP-12 Quad 以及 CXP-12 Interface Cards 的 applet 文件。
Exposure Mode Trigger Width 和 Trigger Controlled#
若要使用外部訊號控制曝光時間,您可以透過下列兩種 Exposure Mode 來達成 Trigger Width 和 Trigger Controlled.
- 使用
Trigger Width如果您將觸發訊號直接連接至相機的 I/O。 - 使用
Trigger Controlled如果使用 CXP 觸發封包且觸發訊號是透過相機傳送。
Exposure Mode Trigger Width#
若要使用 Exposure Mode Trigger Width,您必須在相機中設定下列參數:
- 若要切換至此 Exposure Mode,請將相機參數設定為
Exposure Mode=Trigger Width. - 若要設定觸發,請進行下列參數設定:
Trigger Selector=Line StartTrigger Mode=OnTrigger Source您連接觸發訊號的 I/O,例如Line1.- 如果您有反相訊號,您可以選擇性地設定
Trigger Activation=Falling Edge.
在 Exposure Mode Trigger Width中,相機直接使用來自 I/O 的觸發訊號,而非透過 CXP。因此,如果您選取此 Exposure Mode,則不需要為擷取卡配置任何觸發參數 Trigger Width.

Exposure Mode Trigger Controlled#
若要使用 Exposure Mode Trigger Controlled,您必須在相機中設定下列參數:
- 若要切換至此 Exposure Mode,請將相機參數設定為
Exposure Mode=Trigger Controlled. -
若要設定觸發,請設定以下參數。這會透過 CoaXPress 觸發來開始與結束 Exposure Time:
Trigger Selector=Exposure StartTrigger Mode=OnTrigger Source=Cxp Trigger 0.

Trigger Selector=Exposure EndTrigger Mode=OnTrigger Source=Cxp Trigger 1.

現在,您必須將擷取卡設定為產生 Cxp Trigger 0 和 Cxp Trigger 1 觸發封包。您有以下三種選項:
- 預設會使用內部產生器:

- 如果您變更
LineTriggerMode參數設為Async Gated Trigger,即可使用 I/O 訊號來控制 Exposure Time:
- 或者,您也可以將 I/O 訊號直接繞送到
CXP Link Trigger 0和CXP Link Trigger 1以控制曝光的開始與結束:
檢查影像#
microDisplay X 提供多種方法來檢查所擷取的影像。當您想要校正相機時,以下項目非常有用:
- Line Histogram 檢視
- Line Profile 檢視
- 瀏覽所擷取的影像序列
- 取得像素值或放大檢視每個像素
- 儲存目前影像或影像序列
如需詳細資訊,請參閱 Basler Product Documentation 中的 Examining Images 主題。
複製 SDK 程式碼#
若要將組態複製到您的 SDK 程式中,請選取任何參數的 Details 並複製 SDK 程式碼。

或者,您可以在 microDisplay X 中儲存組態檔,並將其載入您的 SDK 程式中。如需詳細資訊,請參閱 Basler Product Documentation 中的 Saving Applet Configuration 主題。
若要使用 GenTL,請遵循相同的參數組態。您可以在 %GENICAM_GENTL64_PATH% 目錄中找到 GenTL Producer。